Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 11, 2025 - 03:00 EST
Scheduled
Please be aware that on January 11, 2025 from 08:00 am UTC to 10:00 am UTC, the QAComplete team will conduct a system upgrade. QAComplete will remain unavailable during this time.
We apologise for any inconvenience this may cause, and assure you that we will do our best to minimise any disruption to your experience with our service.
Posted Jan 08, 2025 - 09:32 EST
This scheduled maintenance affected: Web Application, API, and Jira Integration.