Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 03, 2024 - 03:30 EDT
Scheduled
Please be aware that on August 3, 2024 from 07:30 am UTC to 10:30 am UTC, the QAComplete team will conduct a system upgrade. QAComplete will be unavailable during this time.
We apologise for any inconvenience this may cause, and assure you that we will do our best to minimise any disruption to your experience with our service.
Posted Jul 24, 2024 - 03:45 EDT
This scheduled maintenance affected: Web Application, API, and Jira Integration.